Объявления
Формулы массивов в Excel

Этими формулами редко кто пользуется, и не все пользователи Excel с ними знакомы. Разберём самое простейшее применение такой формулы - расчёт товарного чека.

Для расчёта мы имеем два столбца: цена (массив B2:B5) и количество (массив С2:С5) товаров. Если идти обычным путём, то нужно было бы создать в этой таблице ещё один столбец D2:D5, перемножить в нём попарно значения цены и количества, а внизу подбить сумму полученных значений. 
Но мы сделаем красивее:
- выделяем ячейку С7
- вводим с клавиатуры =СУММ(
- выделяем диапазон В2:В5
- вводим звёздочку (знак умножения)
- выделяем диапазон С2:С5 и закрываем скобку
- нажимаем Ctrl + Shift + Enter (не просто Enter, иначе Excel не воспримет эту формулу, как формулу массива) - при этом вся формула автоматически заключается в фигурные скобки и становится формулой массива. Это можно видеть на рисунке в строке формул. При этом никаких лишних столбцов и формул не нужно.
Если вбить такие скобки вручную, то эта формула не будет восприниматься в Excel как формула массива.
Это самое простое применение формул массива. Существует ещё много способов применения - от транспонирования целых таблиц до расчётов целых таблиц одним движением, для выборочного суммирования, для вычисления средних значений без учёта нулей, определения количества различий в диапазонах и прочих целей.

источник

Поделитесь полезным материалом с друзьями:


Вам помог этот совет? Вы можете помочь проекту, пожертвовав на его развитие любую сумму по своему усмотрению. Например, 20 рублей. Или больше :)

Передать $пасибо! нашему сайту через систему Webmoney
Добавление комментария:
Ваше Имя:
Ваш E-Mail:

Полужирный Наклонный текст Подчёркнутый текст Зачёркнутый текст | Выравнивание по левому краю По центру Выравнивание по правому краю | Вставка смайликов Вставка ссылкиВставка защищённой ссылки Выбор цвета | Скрытый текст Вставка цитаты Преобразовать выбранный текст из транслитерации в кириллицу Вставка спойлера
Код:
Включите эту картинку для отображения кода безопасности
обновлять капчу